Error with "python -m remo_app"

Hi,
I’ve got this really strange error when running “python -m remo_app”:
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0230

I don’t understand this error and can’t find a clear explanation.
My set up is ubuntu 20.04 with firefox as default browser.
Cheers for any help.

@Nicolas_M thanks for reporting the issue

I’ve checked a few treads, and this issue related to newer version of glibc.
one of the solution could be to try downgrade glibc to 2.30-3

But can you tell, do you have this issue only when starting the app? When do you use your browser, everything works well?

When the application starts we launching electron app, which I guess was build with older version of glibc, so if it the issue only with our electron window, then in config file you can change viewer to ‘browser’.
Config file location: ~/.remo/remo.json

Alternatively you can try docker version, check our docs https://remo.ai/docs/docker-installation/

thanks for the reply!

I saw a couple of posts suggesting to indeed downgrade, followed by a series of posts that said doing so would basically destroy my OS.
Basically i’m following the object detection tutorial Remo provides: https://remo.ai/docs/tutorial_pytorch_object_detection/

When I run “python -m remo_app”, I get the aforementioned error in the terminal, and the following window appears:

Screenshot from 2021-02-05 12-06-19

Which would indicate it works but then when I launch a jupyter lab or notebook, I get a second error indicating that remo has no attribute set_viewer which I take to be linked with the above error (may not).

Hi @Nicolas_M!

The error “no attribute set_viewer” seems related to the python library not finding a running Remo. This could be related to the above error or not, not sure.

A couple of suggestions:

  • can you try changing the default viewer to ‘browser’ in Remo.json, and then try to launch Remo from the command line?

This was Vova’s suggestion, not sure if you tried it yet? You can read about the config file here:

  • from the python library, after importing Remo, can you try to do ‘remo.connect()’ ?