Initialization failure

Being trying to install remo.ai for the last couple of days but whenever i run the initialization command python -m remo_app init
i get the error in the screenshot attached

Hi @Obafemi_Ogunkola , thanks for reporting the issue.

Can you try to install psycopg2 manually:

pip install psycopg2

This library is used to connect and work with PostgreSQL.
After you install the library, please try running again

python -m remo_app init

to finalise the installation process.

In the meantime, we will fix the issue.

Hello, I tried but i still recieve the same error

@Obafemi_Ogunkola on your screenshot I can’t see which version of remo you tried to install. In PyPi, at the moment available version 0.3.41 from 8th of May.

To fetch latest version of remo, you can do:

pip install --upgrade remo

@Obafemi_Ogunkola EDIT

We managed to replicate the issue - this is due to the space in your home directory OGUNKOLA OBAFEMI.
We are releasing a fix for this, you can download the latest in a couple of hours

i am facing this issue:

C:\Users\Admin>python -m remo_app init

===============================================
((
(>’:’) Remo: v0.4.5

Python: 3.8.1, Windows-10-10.0.18362-SP0

Initiailizing Remo:

This will download and install the following packages as needed:

  • vips
  • postgres
  • scoop
  • git
  • unzip
  • aria2
    Do you want to continue? [Y/n]: y

[-] Installing vips lib


[-] Installing postgres
Traceback (most recent call last):
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\runpy.py”, line 193, in _run_module_as_main
return _run_code(code, main_globals, None,
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\runpy.py”, line 86, in run_code
exec(code, run_globals)
File "C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\remo_app_main
.py", line 3, in
app()
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\typer\main.py”, line 211, in call
return get_command(self)()
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\click\core.py”, line 829, in call
return self.main(*args, **kwargs)
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\click\core.py”, line 782, in main
rv = self.invoke(ctx)
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\click\core.py”, line 1259, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\click\core.py”, line 1066, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\click\core.py”, line 610, in invoke
return callback(*args, **kwargs)
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\typer\main.py”, line 494, in wrapper
return callback(**use_params) # type: ignore
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\remo_app\cmd\cmd.py”, line 55, in init
db_config = installer.install(postgres=postgres.get_instance())
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\remo_app\cmd\installer.py”, line 333, in install
return postgres.install()
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\remo_app\cmd\installer.py”, line 212, in install
if not self._is_installed():
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\remo_app\cmd\postgres.py”, line 55, in _is_installed
self._set_env_vars()
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\site-packages\remo_app\cmd\postgres.py”, line 91, in _set_env_vars
if not os.path.exists(os.getenv(‘PGDATA’)):
File “C:\Users\Admin\AppData\Local\Programs\Python\Python38\lib\genericpath.py”, line 19, in exists
os.stat(path)
TypeError: stat: path should be string, bytes, os.PathLike or integer, not NoneType

Hi @DHWANI_PATEL, thanks for reporting the bug!

We are having some issues with automatic installation of Postgres on Windows.
We just released a new pip package (v 0.4.8) that should solve the problem, can you try to download the latest?

pip install remo --upgrade
python -m remo_app init
python -m remo_app 

If it doesn’t work, you can try by installing by postgres manually:

  1. Install scoop: https://www.onmsft.com/how-to/how-to-install-the-scoop-package-manager-in-windows-10

  2. Manually install postgres: scoop install [email protected]

  3. Run again python -m remo_app init

Let me know how it goes!

actually now it shows this:
[-] Installing postgres
Password for user postgres:
Launching postgres …
$ pg_ctl start
$ pg_ctl start
$ pg_ctl start

You can stop Postgres server with following command:
$ pg_ctl stop

$ psql -U postgres -c “create user remo with encrypted password ‘remo’;”
Password for user postgres:
$ psql -U postgres -c “create database remo;”
Password for user postgres:
$ psql -U postgres -c “grant all privileges on database remo to remo;”
Password for user postgres:
ERROR:
Failed connect to database:
{
“engine”: “postgres”,
“host”: “localhost”,
“name”: “remo”,
“password”: “remo”,
“port”: “5432”,
“user”: “remo”
}

the previous issue is being sorted by restarting the laptop ,
Thanks @andrea for the support I"ll be posting for the help if needed in future !

1 Like

hi @andrea ,
if possible how can i use remo in django’s view?

Thanks @andrea for the support I"ll be posting for the help if needed in future !

@DHWANI_PATEL restarting windows is always the solution to all the problems :smiley:
great to hear it got sorted out! And absolutely, here to help. :slight_smile:

If I can ask you to tell us what you think of the app? we are trying to improve things, but we need to understand better what people think to not fly blind… Welcome to remo - this our vision. Tell us what you think!

if possible how can i use remo in django’s view?

What do you mean with “Django view”? Do you want to see the list of endpoints?
if you can share what you are trying to do, maybe we can help and offer some tips.

Not sure if you saw it, but you could also have a look at our python library / sdk : https://github.com/rediscovery-io/remo-python

Andrea